Finow X5 AIR won't update date and time from phone

Dear all my friends!

I have this watch for 4 years and now I want to give it as a gift to somebody.
I used it with SIM card, but now it will be used without SIM.
I reseted the watch, and connected to my phone with original Watchhelper app and Watchdroid too. (Not simultaneously)
I found that the date and time on the watch didn’t synronized.
Is it too much for me to expect that if the watch is paired with the phone, the date and time will sync?
Not everybody use the watch with SIM, then the network give the correct date and time.
Cheers Palko

I believe this watch is running Android 5.1. From my memory there is a date and time setting function in the settings app. It should not require any other connection to adjust the time.


@Jonathan_Bickel that is correct.
Thanks :+1:

1 Like

I don’t have an Android 5 watch handy right now. That’s why I can’t describe the exact way to you. You need to look in the “Time and Date” settings. The automatic time must be deactivated here in order to be able to set the time and date manually.


Dear Jonathan, G1NTONIC, pablo,

First of all, thank you, your answers!
Yes, the watch runs Android 5.1.
I know there is the date and time setting, how to set it up manually in the Android.
When you get a new phone and you put a SIM into this, you don’t need to set the correct time and then (for example when you go to a new time zone) the mobile service gives the always exact time information to the phone.
I have only Android watches, this was the fist and now I have a Lemfo LEM 14 (and I use WatchDroid, not the original app).
I always used them with SIM.
I thought, when I connect the Finow X5 AIR - whithout SIM - to the phone and didn’t do any settings, the phone gives the correct date and time to the watch.
In the Watch Helper app I can see this:

I thought it meant what I wanted, but it doesn’t work.
And I can’t even find anything similar in WatchDriod.
Whoever gets this watch is a tech illiterate.
I can’t tell her every spring and fall when the time needs to be corrected, go into settings, datetime and correct it manually.
I don’t know if Android knows daylight saving time or not.
The phone had a SIM or an internet connection and could always be updated from there.
I would like to achieve that if the time changes on the phone, the clock will accept this and change automatically. You don’t have to do anything for this, just connect to the phone.
WiFi is not a solution either, I can’t keep it on all the time because it drains the watch’s battery a lot.

You can share internet through the Bluetooth connection of your phone, then it will work.


Dear @Eric_Crochemore

At first I thought it was a good idea.
But I always share the internet via bluetooth, because I have an Android head unit in my car and this device receives internet from my phone via bluetooth.
On the other hand, at home, where the phone is connected to the Internet via WiFi, Internet sharing is not possible. At least the Hot-Spot is definitely not working as I know.
My phone is running Android 13 and the watch is running 5.1. Is this a big step?
Also when I install Watch Helper I get the message that it is not made for this Android.
When I try to set the apps that can send notifications to the watch in the Watch Helper app, my phone says: This is not possible.
But I won’t give up!

Android 5 is about 9 years old. I wouldn’t spend much time looking for a solution. In fact, it is enough to briefly activate the WLAN twice a year to update the time. That shouldn’t use too much energy.
But of course that’s just my personal opinion.