Estrange battery behavior..... From 8am to Now paired with my phone....

Estrange battery behavior… From 8am to Now paired with my phone… 5 minutes ago, about 55% of remaining Batt…suddenly, I see that 30% of bat Notification appears, I see the battery and only have 15% :hushed::hushed::hushed:… The battery statistic graph shows a big drop…

Wakelook detector does not say anything rare…

What have it happened?

Install gsam battery monitor to find the problem

I already have installed it… and It didn’t say anything…just normal usage… I don’t know what happened

Could be a bad battery or your charger pins are not connecting properly

I think, could be a faulty battery… It appears to work well right
now… Let’s see

Ok, the charger is a known problem though so check it out. Make sure all the pins are the same length and that they have a little springy feeling to them.

By the way, which watch is this?

no… Both the watch and the charger are new. And, you can see that the
problem happens using it… BTW… Today seems to work well…

I’ll check it next days

It’s a K9


Hi. I have the same phenomena with my D5. It gradually goes from 100% to 60% over most of the day and then suddenly drops from 60 to 30, just within 20 minutes or so and then drops to 10% or lower in the next hour.

I had big problems with even making it going through most of the day.

But, I found out something. This watch (and probably yours as well) HAS TO BE CONNECTED TO THE INTERNET AT ALL TIMES.

Without internet connection, it will, at some point, start looking for something, or tries to connect to something and will not give up.

Also, if you activate location services, it drains your battery real quickly.

In my case, the solution was to allow internet over Bluetooth on my smartphone and on the watch, activate the the use of internet over Bluetooth.

Since then, my watch is always connected and I get much better battery life.

Hope this helps you.

You can put it in flight mode and it will stop this behaviour if that is what you need.

Also - many bad behaviours are fixed by doing a clean flash of stock firmware - if you know what you’re doing and are comfortable doing it …

I’ve tried putting it into flight mode… no work. I’ve tried power saving, nope. It just has to be connected. That’s it. Flashing the latest firmware helped a bit, but didn’t solve the battery problem. I guess it’s because it runs Android. There is always something that tries to update, connect, give info, tries to advertise, or I don’t know what. You can’t stop it, unless you’re a IT expert and know how to root, modify and I don’t know what.

Just keep it happy by being connected at all times.

if you install google’s gesture search and type sync - you can disable all the sync options.

I get a couple of days out of mine with 2G only always connected and making a few calls etc etc