DM100 or LEMFO LEMT Hard Factory Reset or Boot into Recovery/Safe Mode


DM100 android 7.1 or LEMFO LEMT

Does anyone know any way to factory reset using just the two hardware buttons on the right side of the device? or even a script to force it via android studio (cant accept permissions by the way)

Would a USB mouse work to navigate?

I am in a bit of a jam. I’ve had my DM100 Since Christmas. In early Jan I was playing with developer options and enabled the secondary display mode 4k. now I cant navigate back to developer options to reverse my actions because the overlays prohibit input or selection (as I cannot navigate to the top overlay).

I can use google assistant to navigate to some functions via voice but this is it. The watch has been unusable for well over a month.

I have researched the manufactures website and looked in the users’ manual, all to no avail.

You can use adb commands to reset the watch.
Try this :

adb shell am broadcast -a android.intent.action.MASTER_CLEAR

so… im a complete newbie (googling how to run the script in studio) can you give me insight ?

If you have already Android Studio, just go on the Terminal tab and copy/paste my line. Sure you need to have the watch connected. If that doesn’t work (if the watch ask confirmation and you’re not able to do the confirmation), then the FW flash is your last solution.

Thank you. (1) How do you access the terminal mode
(2) What to do if the watch’s usb port is by default onc harging?
Thanks for your help


tested any combinations of harware buttons pressed while watch is OFF and then connecting it to USB?

If you don’t have android studio you can download the platform tools from here, unzip the file and change directory to that folder in command prompt
Then run the command, it will work only if you have already enabled usb debugging and allowed it or if you can somehow click ok on the rsa fingerprint dialog

yes… I have tried every imaginable combo to no avail… I want to flash the command line but I can’t accept the fingerprint ID from the computer.

then, as Eric said, you have to flash the firmware

Enabling usb debugging is not set and without access to the menu I can’t activate it. It’s in charging mode, the mode in which it was when a badly behaved update to a program stopped android from working. What cabn I do please?

I don’t get the charging mode part, but if you can’t enable usb debugging you’ll have the flash the firmware
Next time enable usb debugging and set it up with your pc before doing anything else in case something goes wrong, that’s what I do

1 Like

I couldn’t do that as no menu appeared when I connected to a usb port. Eventually I found that BT was still active in the background and that the pairing had been preserved (though I could see nothing on screen). So I connected to my android smartphone via BT, went to my google account in the smartphone and was able to erase/reset the watch. I have now reinstalled everything but the faulty (updated) software program and all is swell now. Thanks


awesome sauce!!! This is soooo logical and helpful !!! I am back in business.

Thanks everyone for the insight and help!!!

This option worked for resetting the device

(It did not answer the initial topic) using the hardware buttons to perform the hard reset… )

Hi guys, I was looking up ways to unlock my dm100 smart watch as I forgot the pattern I had set on it does anyone here know how may I be able to either unlock and reset my pattern or just factory reset my device (I do not have important data on there so it’s ok if it erases all data).

The only way is to flash the firmware.


Thanks for the reply, actually I am a complete new person to all of this, would you be able to guide me to a video or forum which describes how to flash the firmware.

How much storage has your watch?

1 Like

Also I do not have access any access to my watch I am just stuck on the start screen and it’ll let me in only when I have entered the correct pattern

You don’t need to unlock, to flash. This is why it can help you.

Thanks for the information man, my watch has 3 GB ram and 32 GB rom