Dear All! I have Finow X5.

Dear All!

I have Finow X5. I put in sim card, but GPS don’t work!
Few program told me, my smartwatch doesn’t have GPS.
Do you have any idea?


this watch have gps, make sure that you marked data connection, gps worked for me fine on the D5 and now on the X3+.

Yes, I know, but don’t work it! :frowning: I tried everything.

@Zoltan_Pivarnyik ​ 3g works? Try the Google play store and see if it opens. Also try with wifi and gps on to see if the weather app works.

Yes, 3G is work!

@Zoltan_Pivarnyik see if gps and wifi on the weather app works

I want to use runkeeper, but it can’t find gps signal. And i use gps test app, but can’t find gps signal. I can use internet and call, but can’t use gps

Try to open Google map and see if it shows you your location if so the problem is with the app and not gps, I use JogTracket and works great with gps.

if i open google map but don’t use internet and wifi, it can’t finde my position

missing/deleted image from Google+

When you check gps make sure you are in an open place it hard for it to read in closed places and need wifi or 3g, if you still not getting a lock reset the watch and check if it helped and also check on the forum for latest updates for the watch

@sonia_sophie_ataunna can you use the HR in jogtracker ?

@Francis_Girard no, but you can with BLE HR cheast belt.
i use the app Cardiograph for HR because it uses the builtin sensor.

@sonia_sophie_ataunna ok i try it.
I look and look but i dont found anything. …

you can also try Momentum which has all in one too.

@sonia_sophie_ataunna i type momentum in Google play and i dont find…its the real name.

@Francis_Girard here’s a link:)
what i like about these apps that you can get into settings without mobizen or change to square look.

@sonia_sophie_ataunna Thanks but i have the same problem with momentum i cant us the HR in the watch.

@Francis_Girard you can’t use in any app only the Cardiograph the HR sensor of the watch, for others you’ll need a BLE HR cheast belt.

Hi All! I wrote Finow Company, and i got answer.
My problem disappeared, so gps working
I used this video:\,