Changing boot animation

Hey there! I have recently got my LEMFO LEM10! Updated it to 1.1 (thanks @pablo11 for publishing these updates here, you are a savor! fixed my GPS).

Also modded logo.bin which has my custom charging images as well as boot logo.
I am also willing to improve the English in the apps as well as some UI elements (contact me if there is a way I can do it for LEMFO firmwares for everyone).

But before that, I want to modify my boot and shutdown animations. I have done the magisk boot modification without preserving verity etc. and now I can delete files from /system, problem is though, whenever I put in my boot animation, it either shows black screen (if done from TWRP file manager), or just the base android animation (if from Root Explorer).

Seems like I am not able to send my bootanimations, so in case any of you need it, ask me, I will do a link upload (if moderators allow of course).

Side note, managed to delete the loud and ear scratching boot sounds, for gods sake, remove it.

Thanks, yes Android 7.1.1 is quite easy to modify and it is good to hear you are enjoying it. :+1:
Once you have posted several times and visited several topics, you will become next trust level up and will be able to post links etc… It doesn’t take long…

Aha I see. But is there any guesses on why is the boot animation issue happening? I havent yet unpacked system.img with file_contexts method.

I would guess that the new boot animation doesn’t have the right permissions.
And also may be symlinked.
But it’s been a while since I tried messing around with these things.
Have you made sure that the animation format is correct as well?
Just ideas…

Yeah it is. desc.txt consists of the following

320 360 30
p 1 part0
p 0 part1

All the image files are 320x360

Fixed it! And for those who want to know how to modify their boot animation, here is a guide.

Patch your boot image with Magisk, make sure to disable “Preserve Verity” otherwise you will not be able to perform any operations on the file system, even through recovery.

Make your boot animation, MAKE SURE ITS 27 FPS! (My kistake was that desc.txt was set to 30fps which rendered the boot animation plain black screen.

Copy it to your file system, goto TWRP recovery, mount System, goto File Manager, delete the previous animations (you can also delete the sound files), and copy your new animations. Voila!

Yep, works on Android 7.
At least until a factory reset…

Yeah, now my next question is. How to modify system.img, no tool is able to repack the system.img in a way that makes the watch not get stuck at bootloader.

I have read that I need to somehow use file_contexts (I got file_contexts.bin from /). But no clue on what software to use. Would be nice if you could help.

Who knows? Maybe I would launch my own smartwatches based on DM20 that is, with my custom firnware and app.

We are already working with the solution provider (not the brand and not the factory) to make an Android 10 firmware for the DM20 (MTK M6739 version)

It works like this:
Factory designs a new model.
Brand orders how many they want (other brands may also order) and have their name put on them.
Solutions Provider is a separate company that builds the user solution based on the factory and brand requirements.

Shortly there will be an SPRD Unisoc version of the DM20… Also 3+32gb or 1+16gb.
The S21 model is a similar unisoc powered model but there is also a Unisoc DM20 on the way.
This is because MTK prices have gone up.

However, there is still some M6739 DM20 coming.

So we have joined with the solution provider again to make this M6739 version work with Android 10 and, as an International model, much like the ones that we have worked on already.
A more AOSP + Google based solution.
But only for the MTK model.

Answer to your question:

With magisk and magisk manager installed and the correct busy box installed as well - you should be ok.
It is strongly advised that you have twrp as well.

As long as you have these things you should be able to fix the encryption problem.

A word of warning though.
If you actually sold this model with your own firmware installed - DMN (Domino) will come after you for breaking the copyright they have on this design and board.

Not Lemfo, but the actual owner of the original DM20 design - Domino.
The original design is often referred to in China as the “mold”

So it would be much easier and safer for you to wait a little longer for the official release.

In the meantime you can play around with your own device without problem.

In my opinion.

1 Like

I see. So about the question, what I wanted is to be able to ubpack and repack system.img in a way which can be flashed later on, oh and also, by selling, I mean, contact an Alibaba factory which produces this model with branding options and firmware flashing, and start doing the dropshipping until I can afford to keep my own stock.

Yes, so what I mean is by making the modifications and saving the image with twrp or sp tools read back - you will have your saved image.

But first you need to make sure that it can survive a factory reset.

By the way, you can’t just contact Aliexpress or Alibaba for this.
You have to know someone who can introduce you to Domino because they own the mold.
From there you have to place a minimum order of at least 500 pieces or they won’t deal with you at all.
500 will be quite expensive and it doesn’t get much cheaper unless you order over 1000.

They don’t just sell you a handful.
They only make bulk sales as they are the OEM.

It is far from simple and can be extremely expensive and difficult.
A friend of mine tried this with the Genesis model and it nearly drove the poor guy insane :pensive:

Gosh, thats harsh. But yeah, I got it, will try readback, btw could you also throw me the tool which extracts the readback into seperate images, I had done it for MT6261, but neither I have the tool, nor know if its compatible with my MT5739 (Also mine have gotten Face Unlock after 1.1 update). I have also shot a request for FAW FW Beta, I can give a lot of suggestions and do improvements to the preinstalled apps and may even develop a maps app which doesnt require so precise touches like it is with GMaps right now.

Oh and also here is how the modified “Plug in to charger to boot” looks like on my modified logo.bin

20211005_175258|video

Once you have the ROM 0 output from the flash tool - just use 7zip to open and extract. Done.

Use the tool in this package

Great! Thank you for assistance, I have some work tonight and improved the english of all the watch OEM apps, as well as the settings, however, when I replace the APKs in Root Explorer, they work until the first reboot, after which, part of the apps just plain disappear, like the APK is there, but its nowhere in System Installed Apps, nor in Home Screen, if I do it from TWRP, same thing just without the need of reboot.

Did you set the correct permissions required for these?
It sounds like a permissions problem to me.

Hmm, sorry for late reply, 39*C fever. Can’t seem to be able to chmod on the watch, in terminal, it outputs nothing yet permissions are not changed. Tried from TWRP and Terminal, Tried using Root Explorer, fails to change permissions yet root perms are there.

Then it is not using busybox or you forgot to install it.
Or you don’t really have root access.

My advice is to install busybox and make sure you can mount system rw

Are you using Magisk SU module and magisk busybox module?

In terminal, is sudo working?

Something is wrong…