Can someone explain how to write/deploy sports mode apps?

Loving my APPLLP 9. Battery last 3 days in sports mode. It has bits like O2 and HR in sports mode. So there is some functionality.

1- Is this “mode” (which I think uses a special processor) a standard thing across multiple manufacturers? Ie if we learned how to write/compile/deploy a sports app on my watch, would it also work on other watches?

2- What limitations does the API (if it exists) have?

3- Where is the API? Can I use android studio? … any info on writing and deploying them.

1 Like
  1. I also have this watch and never used sport mode and got full 24hrs of usage. You cant use apps or export apps from this mode ,maybe with root im not sure.
  2. You can use AS but to modify the system and apps in it i think you need also root.


@billsaun I am really surprised that you haven’t noticed that so called “sports mode” on these watches is fake? (since the Optimus 2)
It is nothing but the same as the usual mode, apart from the launcher.
The launcher just hides most apps from the user when you switch modes.

The pixart BT chip prevents the old “dual system mode” that was used on the Optimus Pro with the amoled screen.
And the Lemfo LEM 9, Thor 5 and Optimus Lite.

These old models used to have a real dual operation mode which switches you to the BT chip after a full reboot and hence no calls were possible and operation was indeed very restricted.

So, when you switch to this more modern “sports mode” the apps are exactly the same as any other apps that you can install.
The only thing is that the “lite” launcher will hide them.
This cannot be changed.
However, given that there is no other difference between the two modes apart from the launcher - it’s not a problem.
Just don’t use the restricted “sports mode” launcher.
It’s a placebo… (if you don’t see those apps it must be saving power, right?)
It makes no difference at all apart from stopping you accessing apps that might use power, if you launched them.
All the same background tasks run in both modes :joy:

If you check out the Prime S and the LEM P threads, I explained it there as well.


@pablo11 Thanks for the great reply. (I’ve often wished search engines ran some bayesian statistical near word feature in search…I type “sport mode” and because of other articles having mode, sport mode, dual mode…it recommends “dual mode” as another search term. I need to search deeper.)

This is awesome news about the launcher…theoretically if I replace the launcher, I could run other apps too. So then it becomes…something must be eating the battery and the “Sports Mode” prevents that app from starting…in the background?

@sonia_sophie_ataunna is right, on my Lokmat APPLLP 9, if not in “Sports Mode” I get about 4 to 6 hours just with the watchface and nothing else being done. In “Sports Mode” I get 24 hours with an occasional BP or SO2 reading.

So I definitely believe you Pablo that it’s the same “mode” and not running on a different lower power CPU. Next time I’m hacking, I’ll adb shell cat /proc/cpuinfo and ps. I have not tried adb from the sport mode.

Perhaps some form of pm uninstall debloat + a power watcher to kill procs/shutdown bt/wifi, and some airplane mode can get the apps I want to run to last 24 hours.

Still thinking of a cheap 3d printer => thin shim charger plate running wires to the watch band holding a second battery.

What are you using that your watch last only 4/6 hrs? Go into settings and there go to battery and then intansive apps usage. Do you leave wifi always on? Do you use sim? Which companion app do you use?

I have lokmat 9 and i use 24/7 sim with 3g/4g , auto weather update, HeartFit, gps, Bridge, BT, Google Fit, One Calendar, geasture search, touch pro, Whatapp, and some few more apps which dont have much impact on battery life, the only one thing i havent done yet is add more watchfaces. I get 24hrs of usage.

1 Like

Thanks for confirming that the watch does last. Sorry about the late reply. Life.
So I hacked my watch by doing a bunch of adb shell pm uninstall’s to clean out built in apps I was not using.
Then I installed a bunch of my own apps. sshelper, vnc server, …
I though I must have loaded something that drained the battery so I uninstalled everything I put on.
Still no luck. Battery drained in 6 hours.
So I thought maybe I pm uninstalled something I should not have…
Factory reset the watch…
It wont boot. :frowning:
Oh well, I’m going to see what I can do. Its not dead but stuck in a boot loop.
Time will tell…

Just flash the stock firmware using the firmware upgrade option in the flash tool.
I take it you got the firmware before you did these things to the watch?
So you can flash back if needed.

1 Like

Nope…some lessons in stupidty are costly.
I was just pm uninstalling and I imagined that a factory reset would fix all that.
Live and learn…