App not fitting screen, used to but now shows half

I’m curious if anyone has a suggestion on what to do here, I used to run Old School Runescape on this watch and it worked very well. I recently did a factory reset on the watch and redownloaded the app to find that now it only displays the left half, I’ve gotten into the developer options and poked around with no success. Any help is appreciated thank you.

Press and hold the power button. Choose round mode.

1 Like

Unfortunately that just zooms up the screen a little but leaves half of it cut off.

And it was working before? Have you tried to delete the app completly and reinstall?

Also I have uninstalled and reinstalled as well as a second factory reset and reinstall with no luck

Yes it was, I even had a video on reddit showing this exact watch playing this exact game if you google “kospet runescape” its likely the top link with a title “with this i’ll never xp waste again” and I’m pretty sure it was a dev option that i had changed last time to make it fit but I don’t know for sure because it’s been so long. Whats funny is runescape 3 loads up just fine right now but oldschool shows the left half only.

@Teebow do you have any advice for this guy?
I believe you know quite a lot about games on the watches…?
Thanks in advance :+1:

1 Like

I don’t have the Kospet Optimus 2 but I tried this Old School Runescape game on the Kospet Prime 2 and the LOKMAT APPLLP 4 PRO and there is the exact same problem.

I tried all the tricks I know and couldn’t get the game to work properly.

I think it’s a problem of resolution it seems that this game is made to be wide there must have been an update of the application because before it worked well apparently.

Cheers :handshake:


Thanks @Teebow
Did you enable third party app scaling in the “Optimisation App”?

Yes I tried and it didn’t change anything.

I also tried to connect a Bluetooth controller to be able to access the options of the game that we do not see on the screen to change the resolution but there it does not work.

I also tried scrcpy but nothing more is seen.

1 Like

here’s the version that was the most recent when @K-Lub posted the video to reddit:

1 Like