Anyone ever experience an issue on their D5 with wifi cycling through "Authenticating..." and

Anyone ever experience an issue on their D5 with wifi cycling through “Authenticating…” and “Obtaining an IP Address…” and never fully connecting? It’s been working fine since I got it, but this morning, my D5 (newest stock firmware received OTA) started this issue. I also tried connecting to the hotspot on my iPhone with the same result. Wifi doesn’t want to connect fully to any network anymore. The Bluetooth tethering (through iPhone) connects, but there it still seems to lack connectivity as the Play Store prompts for a wifi connection to allow logging in and the browser won’t connect to web.

  • My first step was to do a power cycle. Same issue.
  • I tried changing the wifi password to less characters. Same issue.
  • My next step was a factory reset (first since I received it). Same issue.
  • My next step was to change the power setting so the network stays connected (longer) if the display is off. Same issue.
  • My next step was to leave it powered off for 30 minutes. Same issue.
  • I just searched the xda forum threads and this community for anyone with the same symptom with no results.
  • This step is to ask if anyone here has experienced the same symptom and found a resolution.
  • My next step will be to remove the back and pull the battery cable.
  • If that doesn’t work, I was going to try flashing Lokifish’s ROM.
  • After that, I guess I’ll RMA it with GearBest.

Thanks in advance for any ideas or assistance.

  • I followed through the next step of removing the back and pulling the battery cable for 30 minutes. Same issue with WiFi not fully connecting.
    – I set my router to provide a static IP Address for the watch…because during a google search I found people resolving the issue by setting their phone WiFi connection to a static IP. I can’t find a way to set it statically from the watch, though.
  • I backed up the files on the watch that are accessible via USB and performed a factory reset with erasing equipment storage. Same issue.
    – It seems that the factory reset didn’t fully complete, though. Now, if I open the File Manager app, there is no files or folders. If I try to create a folder in that app, it says “Insufficient space.” and no folder is created. The SD card also isn’t accessible from Windows while connected via USB.
    – Lastly, when attempting to follow Lokifish’s instructions for the TWRP and W812a ROM install, I see the following in MTK Droid & Root Tools when the watch is connected via USB:
    —>>> Connect to device <<<—
    ATTENTION! File /system/recovery-from-boot.p which restore factory recovery in case of phone switching on in a normal mode Is Found!
    – I tried using adb to remove the file (it seems to be a failsafe from possibly the failed factory reset?), but adb gives this message: CANNOT LINK EXECUTABLE: could not load library “?ibc}” needed by “rm”; ca
    used by library “?ibc}” not found

I know there is a lot of information in this post, so I apologize for that. I hope you see that I’ve tried to resolve this issue myself with a lot of research. If anyone can either point me to something I haven’t thought to do, I’d appreciate it. Of course, if I should just RMA the watch…I’ll do that as well.

I was able to resolve all these issues my flashing the latest firmware from No.1 for the D5.