Any one knows a way of hard resetting the KW88?

Any one knows a way of hard resetting the KW88?

In short this is after installing watchnew.apk that isn’t compatible with the watch.
Can’t uninstall,can’t reset…hard reset maybe?
Watch is accessible once started (black screen) because it is showing through cable on pc .
When in off position its only a second connected with windows and the it disconnects so not able to flash.
Energy options usb are off…drivers are correct, even tried a powered usb hub as well as other computers.

@Martin_Nijhuis , As I do not know I ask. The flashes of KW88 is like D5 but with different firmware?
That is the clock in off and then blink?

Flashing is I think just like D5 , with watch off and having firmware and flash it with Sp Flash tool

that’s the opening screen …from here it should go and find the watch faces .Can’t find them because I installed a wrong watchnew.apk

Wow …ok Will try that but…
I kept on pushing the button in a bit of anger …it turned on and off and on and off and when I let go it said optimizing apps…still waiting but its counting so I’m holding my breath here.

It optimized the apps but when done it showed the same flickering screen in search of the CF …so it optimized the apps that were installed by me too…thought and wished for a moment it was a hard reset but apparently it was a soft one…pfff.
@Lokifish_Marz I’m afraid if I do what you proposed I’d be stuck in the middle of a flash and then the old fw (which is still on here ) will be screwed and even a hard reset won’t help?

In off the connection is a Mediatec one …straight to the rom through a port number.
In on position it is a straight forward usb one.
When not rooted this usb one will not get you (or the fw) to the rom.
If I turn it off…the connection will go from usb to mediatec and the flash may begin but…a second later the connection will fail I’m afraid , happened all the time…in that case only a part of the fw will be flashed and the watch is more broken then now with th eold fw and not being able to flash.
I need a way of hard resetting this thing or a way of flashing while on or sideloading a new better watchnew.apk or deinstalling the fucked up one (I thank him for giving it here .NOT, although I was stupid enough to go right ahead and install)

I call it a day for now , spend some time with family now :wink: tomorrow I hope to have enough to read here :wink: and maybe some of you will have the golden solution for it…any tips are welcome…thanks for any help you guys gave me already!

@Martin_Nijhuis , I have the same opinion that @Lokifish_Marz , flash will be the best way. And also I never heard anywhere, even on mobile phones that flash has killed a MTK. They are good, hard to kill and manageable at this point.

Back in business !!!

Flashed it just now and it’s working.
Thank all of you for support and help and moral support.

It was a combination of things that kept the watch from flashing as it should.
The USB ports can keep disconnecting because of setting in the hardware power options. (have disabled this)
This should do the trick but in the progress of finding out what it could be I also didn’t follow the flash instructions to the letter.
When plugged in the watch and it beeped saying it had connected I expected like other hardware to stay connected.
The trick is in this port connection that although you have set it to NOT disconnect in energy settings , it will disconnect when not given a signal to that port.
So …following the instructions to the letter this time I hit download and after that the port gets his signal and the watch has to connected AFTER pressing download.

Now this sounds like me being stupid , and maybe I was…but I thought I done that and couldn’t believe it didn’t work then.

This morning I also used (like yesterday only then the power settings weren’t disabled) a powered hub because some laptops don’t have enough juice on the usb port for the hardware that’s connected with it.

Search the internet …lots of people had problems with it.
Anyway…its flashed now and I can re-install CF again :wink:

Again , thank you guys for holding my hand in the progress and listen to my cries :wink:

Cries it’s good… sometimes.
I’m glad you can make the job and share with us. :ok_hand:

@Martin_Nijhuis Great news… I’m going to read through your posts to see what I’m not doing correctly…
I have tried changing (some/all) of the USB power settings… I’ll have to try harder… :slight_smile:

@Andrew_Davis I didn’t know/realize you had this with your KW88 too?

I didn’t mention this very useful tip from +Saša Petrović .(sorry it (G+) doesn’t quite get the right link)

MT6577 USB VCOM drivers(I know we have a MT6580 but id did the trick and you put in a legacy hardware( device manager> Action > add legacy hardware) and you add the MediaTek DA USB VCOM port<<<

I did this and as I connected the watch (being completely off) it gave the watch (for a second ) another driver quit similar to this installed driver .
As if it doesn’t recognize it until you install the above driver and then when it does gives it his own suitable one.

In other words…the driver the watch needs to be recognized when its powered off (giving it a port)is a completely different one then when the watch is on (giving it usb access)

You can check with watch powered off if its connected although it connects only for a second and then beeps for disconnect it shows a battery on the watch for charging .

After that the most important thing is starting up flash tool (make sure to download the latest one SP_Flash_Tool_v5.1636_Win

Load into it under scatter-loading-file the latest FW for the KW88 (you know where to find) and remove the activation of the preloader (do NOT flash that one)

Hit the download button and connect put the usb cable in your pc (I still left it connected to the watch to make sure it staid well connected there) and leave it be for a while to flash (it shows on the progress bar)

If you have a laptop instead of a big-tower pc or something it may well be the power of the usb ports aren’t sufficient enough .(it’s a well-known fact and well documented all over the internet) you can borrow or buy a powered usb hub that’ll take care of that.
I have a disk docking station that also has 2 powered usb ports so I used that.

Pff …whole lot of words but I hope I explained it well enough and left nothing out telling how I did it after I cooled down and read all the help from the community :wink:

Good Luck and Success !!

o and as for the connection loss with normal working watch on usb>>> I found out that when I restarted (reboot) the watch it connects and stays connected for a while. So if it doesn’t …try reboot.

@Martin_Nijhuis Hi, do you have battery draining issue after flashing?

My KW88 has no faces… I can connect via USB… I have not flashed it… battery drain is very high 3-5 hours…
My D5 has had the latest OTA and the problem of the black/blank faces has gone… but I still can not connect via USB… battery drain is very low… 8 hours and only 1% drop (99% now) :slight_smile:

No I don’t have battery drop but yesterday for the first time I had the battery on 4%. Used it from 0700 till 2300 intensively though. My D5+has arrived… Tomorrow I will have time to explore it and update FW if there is one. And of course put a whole lot of cf on it ;-).
@Andrew_Davis to be honest I don’t think this can be true… This very low battery drain… Would be a sensation.

98% after 12h 10m 22s… :slight_smile:

88% after 22h 26m 34s…

Keep on keeping track… I’m very curious when it will stop and what was the last reading. I recon it will be in the next hour or two…

Or if turns out to be correct that means it will definitely last 4 days! 1%/h

72% after 2d 0h 59m 36s…