Android Energy Management MyRunning App

MyRunningApp stopped by Android Energy Management for my device while recording a workout.
Stopping about every Km.

Unfortunately MRA is showing problems with A10 . Turn off in battery saver and allow app unlimited data access . This app is no further under development

1 Like

make sure all battery savers are off and the myrunningapp is the active app on the watch. I did use it today on a 55 minute run (pulsebelt) and it performed like the prime 1.

1 Like

Now sorted as follows.
Note in MyRunning on board FAQ where “Don’t Optimize” is required.
Settings
Apps & Notifications
Special App Access
Battery optimization
Press right edge of NOT OPTIMIZED to Expose ALL APPS
All apps
Choose MyRunning App
Select Don’t Optimize
Done

2 Likes

Yes, that is exactly the way to go for any app that must run always in background

The latest update has finally solved the problem with AEM which never went away.

My Prime 2 is killing all apps when the screen times out or when I turn it out.
Spotify and Whatsapp (for web) is killed and it’s not usable like that!
I have tried almost everything! -.- Can someone help me out!?
Got it yesterday and have the newest update on it

have you tried turning off the battery saver

1 Like

As @noidremained said.
Apps->Optimization
Either disable optimization completely, if you feel you have battery enough for your usage pattern. Or enter the list of apps, and disable optimization for only those apps you need to run in the background.
Be aware that they are enabled again when the play store updates them, so visit the list again and check after updates.

3 Likes