Weather Data Not Displayed on Universal Launcher

When using Eric’s launcher, the weather data is not being displayed on watch faces. The temperature defaults to 0 degrees celsius or 32 degrees fahrenheit, and the moon and weather aren’t accurate. Any ways to fix this? Using a Thor Pro. I’ve attempted updating the main location in the launcher settings, but when I press the “…” next to the main location, nothing happens, and the other time zones do not make a difference. Thanks for any help!

Have you tried the new version here. I think it has updates to fix this. :slight_smile:

1 Like

Thanks for the help! I do have the latest update of the new gen launcher. I’ve found a solution to this: you have to have location services turned to high accuracy instead of device only for it to allow you to switch the main location. Now that this works, I have switched to New Gen launcher as my main launcher. Thanks, and sorry for posting in the wrong category originally.

I have tried all above settings on my Kospet hope but it’s not working.

Your gps must not be working very well then. Would be great if weather could be set through wifi Alone and no need for gps connection first in UL :slight_smile:

I have done a video about that, just look at our YT channel.


At my end still no weather updates… interesting

You have to set your location first. You’ll find a video about it on our YouTube channel.


It was exactly like that for me, but with universal launcher .With me on kospet power on the older version of universal launcher stopped showing temperature (stopped detecting my location). I installed the new Clockskincoco 3.5.2 one and things happened to me immediately