TWRP Recovery and patched boot for D09 Prime 2

You can only restore them to your device.
If you factory reset or flash stock - I don’t think they will work but I don’t bother with doing this stuff so I am not 100% sure

1 Like

I tried root. Magic works on my watch. I describe what I did, the result is perfect.

  1. I install Magisk 8.0.3
    magisk auto update 8.0.4
  2. Patched the boot.img with Magisk
  3. OEM Unlocking ON
  4. Flash the TWRP boot.img and recovery.img
    and that’s it, nothing else.
    after that I turned on the clock, it started in normal mode and I checked these pictures during the check.

Then I installed REBOOT 2.1.0. apk and TWRP recovery will also start.

I only tried programs that required root access.
IT WORKS

2 Likes

Good work :+1::+1::+1::+1:
Nice to hear that you have had positive results.

“fastboot flashing relock” along with “fastboot oem relock” and “fastboot oem lock” are unknown commands to the preloader. The “fastboot flashing lock” command works, but ask to confirm with the volume buttons, which we do not have. The power button does notting, while the second button seems to cancel the operation. The preloader can however be relocked by flashing the firmware in firmware upgrade mode.

when bootloader is unlocked you can either flash a boot image you’ve signed yourself or flash the “blank” vbmeta and a unsigned boot image. unsigned boot image with vbmeta enforcing avb gives a bootloop as @droidtrix mentioned

it seems @none has found some way to sign the boot image with the same key the stock image was signed with. myself I was able to trick avbtool into thinking it was signed by that key, but the bootloader was not fooled

1 Like

I remember relocking during the dev stage and I was pretty sure that I used
fastboot flashing lock (or relock)

I definitely rebooted immediately and this triggers a factory reset again.

Then I disabled OEM unlock in dev settings on the watch.

Maybe it has changed since then.?

Good idea - I hadn’t thought about that way :+1:

Good to hear gyuri you had luck too and it appears from your pictures that you don’t need the canary version of Magisk to do this either as I think the canary is 4770 instead of 4768. The magic of Magisk is back again :smile: I’ve been wondering about trying the latest Magisk on a boot locked Samsung but haven’t quite wanted to take that chance yet. I think the latest Magisk just came out about 8 days ago. I’ll wait an watch a while but what I’ve seen here gives hope.

That and thanks again to @none for his efforts in this. It would be good to hear how he got the patched boot image also.

1 Like

One of the first things I tried after gaining root was to ‘Freeze’ the fitness app. I wasn’t sure if that might stop the steps counter which I assume is some app that tracks a motion sensor but it did not. Since I don’t use the ‘steps’ I thought it would be another way to save battery life. Does anyone know the app or service that tracks the steps counter?

Thanks, yes I think it was only an option available in the userdebug builds in early development.
By far the simplest method is to flash clean stock firmware using firmware upgrade.

1 Like

After doing a backup with TWRP of Data, NVRam and NVData and then doing a restore of all three of those I can confirm that everything works fine as it should. Great to have that option. I’m not sure if it is possible to backup and restore the ‘Super’ which I assume is the main System partition and restore it but I am guessing that could be restored with the stock firmware using SP Flashtool if not possible with TWRP.

Go on settings, gesture and disable the step counter.

Unfortunately, it is not included in prime2.

There is no point in backing up the super.img in my opinion because you cannot edit it anyway?
Good news about the nv partitions but I doubt you can restore them on the watch if you flashed the firmware again…
Unless you go through the whole unlock process again etc etc…
Because of the differing signatures.
Unless you have already tried this and it worked?

It’s a tricky one because it is running even if you could disable it in settings (as you can on some of these devices).
Even though you think it is disabled, it is actually still running but is not reporting to the OS. So it appears to be disabled but it is just not updating the OS anymore.

I will look into it but I suspect that it has several dependencies and may cause unwanted problems if it is really disabled.

1 Like

the super partition contains the system, vendor and product partitions

1 Like

@noidremained Yes and my understanding is that they can’t be edited or changed even with root.
So I would think there is no point in backing it up…
Or maybe I’m wrong?

I have to admit that I don’t normally mess around with Android 10 images so I am not sure

1 Like

I have a few things left to try and see if I can manage to edit the system partition, but so far it seems like you are right. And I agree that it’s no point backing it up when it’s exactly the same as is included in the firmware available on the forum.

3 Likes

Yes agreed… The image file is in firmware.
But I guess if modification is possible (by some method we have yet to discover) then it might be worth it :+1:

Thanks @noidremained
I have to say though…
Even with the userdebug build with full root permissions and verity disabled - I have still not been able to edit the image…
A10 is great in many ways but it is locked down so tightly.

I suspect that system-less is the only way, and using magisk modules.

I will be very interested to see how this pans out :+1::+1:

Agree that backup up the ‘Super’ is of little use.

Having root now I was hoping I could edit (with little optimism) the APN configs file to change the ATT user editable from false to true but no luck - it won’t save so apparently that is on the Super partition. I haven’t yet tried directly modifying the partition for those settings but I believe that would be very difficult also due to various lockdowns Anroid 10 has. Fortunately I know the SIM swap trick works but it’s a bit more difficult for others to do.

I agree about the super.img. I haven’t tried flashing firmware again. I think I have an app somewhere that can save essential NV Ram data. But if something went haywire and I had to reflash firmware I would definitely unlock, root and reinstall TWRP so as to restore NVram and data that way.