This is how booting up looks after updating firmware.

This is how booting up looks after updating firmware. But the simcard is not longer working. Please someone with knowledge help me fix this. Ive tried many times to re-flash firmware but no luck.

Can you disconnect the watch battery by removing the back cover and detaching the little red and black cables terminated to a plug that sits on the main board? Leave it off for a while and then reconnect and boot the watch. Let me know what happens.
PS: be very gentle with the connector !!

PPS. The cable lifts straight up from the connector, not out to the side. To put it back, position it and gently press down.

@SmartWatch_Ticks One of your videos has a good bit about the battery and connection…

Yea, this one about 5 minutes in shows how to disconnect it:

@Andrew_Davis & @SmartWatch_Ticks

Thanks guys :slight_smile:

I did choose to “Format all+Download” when i ran the Flashtool. Could that be a reason for this?

As stated everything works but not the simcard. I have also tried to install the the first STOCK-recovery rom and then the sim works but there is no playstore installed.

I will try to disconnect the battery after work to see if it helps.

Using Format all + download has never been recommended by us and never will be - it has definitely wiped your IMEI.
Now that you have restored your backup you can flash the new firmware again. In SP Tools (if you want a clean start) select “firmware upgrade” and flash, followed by a factory reset after first boot. If you are not worried about cleaning out any left-overs, just select “download only” in SP Tools and flash.
Because you restored your IMEI with your backup you should be fine to upgrade and you wont lose it again.

When you say “restored your backup” what do you mean?

Factory reset done inside the phone/watch?


I meant in your words “I have also tried to install the the first STOCK-recovery rom and then the sim works”

@Jessie_Lin jessie thanks, I will try this when I get home.

He doesn’t need to do that as his sim is now working after flashing the previous stock rom. All he needs to do now is flash the new firmware and select download only in SP Tools.

@Pablo_Eleven_Pablo11 No that do not work, I tried that yesterday, no good. I will need to try what Jessie suggested after work. I’ll keep you updated. Thanks for all the good support guys/ladies, it means a lot.

@Oyvind_North unfortunately the procedure which was suggested previously is illegal in many countries and carries a heavy penalty in some. I have therefore had no choice but to remove it.
So - please tell me - when you go back to the stock firmware your phone sim works - correct?

@Pablo_Eleven_Pablo11 ​ Yes it works when I install the first STOCK ROM from Finow, but when I update it stops working again.

The strange part is that the finow logo and boot animation gets replaced each time I update the firmware.

Yes - well the new firmware has the spinning globe because it’s the generic version - no brand. That’s fine - it was so that any firm could put there brand animation there and use it.
Tell me what option you select with SP Tool before you flash please ?

That happend when i used format function.

@Pablo_Eleven_Pablo11 I used download only. But that does not help cause imei is gone now

The way I read your post earlier - I thought you had gone back to stock original X5 and that your phone and IMEI were back. Are you saying that you still have no IMEI or working sim/phone?

@Pablo_Eleven_Pablo11 Yes I did have it working but now after the latest update its gone. Its ok I managed to fix it and are now up and running, at least for now.