Reboot loop on Kospet Hope

Eventually it stopped rebooting, after a very long time of the same cycle, I’d say 1.5 hours. At that point it just booted one last time as normal.
I think it might be a problem with the battery, OR the firmware thinks it’s a battery problem and initiates a low-power or battery overheat shutdown. Because right after it finally booted correctly, it said 80% charge, now it immediately says 2% charge within about 2 minutes.

Yes, if the battery is very low, the system tries to boot but has not enough power. So it fails, turn off and tries again. This stupid behavior is present on some watches…
With a good charger, it can ease the watch to boot and reduce that behavior, with only a low power charger 0,5A, it can take some tries…

2 Likes

Unfortunately the watch appears to be bricked now.
It entered another reboot loop today. Eventually it showed a weird bios screen that said something about booting to normal mode or something else but it was automatically scrolling through options on its own so fast that I couldn’t read it.
Then it just turned off with a black screen forever.
Charging doesn’t seem to do anything. Button presses don’t do anything. Plugging the data cable into my computer also does nothing, completely unrecognized.

I reached out to the online store where I bought it to see how to get a replacement…unless anyone has other ideas.

I have just now happened to me this boot loop. It didn’t stop until the battery died and charging it still the same. looping from black screen to battery icon charging. Do you guys have any solutions? It will be much appreciated. Thanks!

Flashing should work ? Maybe worth explaining what went wrong . I also had the bios screen thing happen to me on a H2 . Exact same behaviour years ago . Funny thing was i pressed and hold both buttons tightly for a minute , screen died and went black . I gave up and left watch . A hour later watch was back on ?

Everyday after work i would turn off kospet after i reached home of course. Seeing It was around 54% of battery life i was thinking not to charge it and (since i can still use it the next day) set it aside turned off. Then as i was trying to press the power button (btw, i noticed i’m having hard time recently with the power button not responding properly) to turn it off like i usually do for the past months and that loop happened.

I took the matter to my own hands and I think I may have found the problem causing such loop atleast on my Kospet Hope. Will test it more before I share it with you guys that may have experiencing with same issue.

I am interested in knowing what your theory is about this.
My own theory is that bad quality components make it through quality control testing.
It has always been a problem when so many hundreds of watches are produced and quality control is not very good.

You are correct pablo11. A very bad quality component causes my boot loop issue.
So I decided to take my kospet hope apart to isolate what was causing it. Is it a hardware issue or a software? (please do it at your own risk if you decided to take apart yours. I will not be held liable if anything goes more wrong about your smartwatch. Just here to share.)

The image below, one with the arrow pointing to the momentary switch which is the power button is the issue i found causing my smartwatch to boot loop. The momentary switch was loose and corroded.


The solution i made in order for the watch to function and usable again was to fiddle with the momentary power switch until it worked and didn’t boot loop. Notice the above image where the switch with red arrow(lower button/back button) and with the yellow arrow(upper/power button). I did rotate the orientation of the switch and position it until it was not loop booting since a switch’s work is to short/complete a circuit and open/break it. But i cleaned first the contacts before I did all the positioning which was pretty strenuous attempt every time.
Anyways the tactile feeling of the power switch will no longer be there but hey it will be now working.

I do hope KOSPET will do more quality hardware parts and inspection since most people will not bother attempting on opening their watches. Thanks!


Also thanks for the watch faces you guys put on here! Love and Respect to all of you!

3 Likes

You are amazing xcvi96, to take every component apart to prove that. I took my own Hope apart to a lesser degree when it was having the reboot loop but it’s HELL to put back together correctly so you are a hero.
I completely agree, I’ve got three total watches from Kospet & Zeblaze & Lokmat with bad power buttons where they have to be pressed very hard or at a certain angle or no longer work at all, and short of a complete tear-down and rebuild like you did, it’s such a waste of a good concept for a watch. (And I own exactly one of these watches where the power button is intact and works every time.)

1 Like

I have had this exact same problem Kospet Prime 4G. The reboot loop continued until the battery died. I thought this meant I could recharge and get a fresh start. However on reconnecting to charger the loop is continuing flashing between a flat battery (red static battery symbol) and the Kospet logo - over 3 hours. So can I safely throw this apparent brick away? :unamused:
What is the most efficient reliable low end watch according to stats/complaints/praises of this range of watch anyone?? :pensive:

The first thing to ask is have you flashed the firmware?
If not try that and if that doesn’t work just get a refund by contacting
after-sales@kospet.com and

Prime original is no longer available I suspect but you can go for the Prime 2 or whatever you choose.

I still have and use my original Prime 4G and it is and has always been rock solid.
My Hope is also still working fine.

As I have mentioned before, I believe that a lot of the issues like this are due to the quality control - normally within the first 2 months of production.

By the time a watch has been in production for around two months they will have sorted out the issues…
Just my opinion.

2 Likes

Thanks Pablo for your quick response. Is it possible to flash even though it will not start to begin with? If so I will need detailed instructions coz it sounds tricky. I am willing to try coz I really liked this watch. Thank you so much!

I guess we are talking about the Kospet Prime, not the prime SE?

Here is the latest firmware:-KOSPET_PRIME_v2.6_B_20200908.7z - Google Drive

Here is a tutorial how to do it:-Flashing Tutorial.pdf - Google Drive

Here are the needed tools:-Flashing Tools.zip - Google Drive

1 Like

Yes G&T, not the SE. If this works I’ll get you a G&T guys. If not, thanks a mill for taking the time to both of you. I’ll ask if i need help otherwise will let you know…fingers crossed…

Followed those instructions to a tee but the flash will not commence on docking the watch. The reboot loop just begins and the flash tool does not respond. I have emailed Kospet as per Pablo advice with pics of what is happening and maybe I might get lucky seeing everything has been attempted.

Ok, please disconnect the watch and wait until the battery is dead again. Then coose “firmware update” in this case and press download again. Make sure that the contacts on the backside are clean, you might use alcohol to clean them. Make sure that the watch is connected to the dock properly. That is a little bit tricky sometimes. At last, connect the USB cable to the computer. Then the flashing process should work.

I have chosen the firmware update option and managed to get this to happen. I will now work on ensuring contacts are perfectly aligned and clean as I am sure this may be a source of my issue of charging.

1 Like

Congrats, you’ve done it. Now charge your watch and then let us pray that your problemsare solved. By the way: No factory reset needed in this case.

1 Like