New update broke my watch!

   My watch got an update pushed to it yesterday and now it will no longer connect to my phone. The bluetooth keeps turning off and on every 5 seconds. I tried re-pairing manually, reinstalling Watch Droid Assistant, and then out of frustration, a full reset. It is doing the same thing. I continually get messages on the watch that my phone is connecting and disconnecting. If I go to the bluetooth setting on the watch, you can see it turning on and off and on…well, you get the idea! Is anybody else experiencing this?

This update has completely ruined my watch. I tried completely removing Droid phone and Droid Watch Assistant from my phone and watch and the same thing happens. Then I tried the most recent version of both apps, which are crippled due to some Google Play issue, and that did not change anything. Is there a way to revert back to the old firmware?


Edit: The watch and phone will stay connected only if you open the Watch Droid Assistant on the watch and leave it open. As soon as you go back to your watch face or do anything else on the watch, it disconnects.

Have you turned off the power saving feature on the watch ?

Jan 5, 2019 15:54:07 GMT 1 ricktop said:
Have you turned off the power saving feature on the watch ?

  Thank you for your reply! Yes, all power saving features are off. Apparently the update broke Watch Droid Assistant. I installed Wii Watch 2 and so far it has stayed connected. That app is the one I used to use on my iPhone, and it pretty much stinks compared to Watch Droid. I may try an older version of Watch Droid assistant later today. The problem is not power, however. WDA just disconnects when you do anything else on the watch. Looking at faces, going into settings, opening apps, etc.

After playing with it a while, the problem persists no matter what version of Watch Droid phone and Watch Droid Assistant you use. If you open the app on the phone, it connects, close it, it disconnects when the display blanks. Maybe it is some sort of power problem. I have all power saving features turned off, battery optimization off on the app on the watch and phone, and Standby Intelligent Power saving is off. So if I open the Watch Droid Assistant on the watch and set the display to time out in 30 minutes, it will stay connected for 30 minutes. ;p(. It seems like when you go to another app or function on the watch, the Watch Droid Assistant service turns off. This is, of course , not an acceptable way to use this watch. Wii Watch 2 seems to stay connected, but I cannot get it to send notifications to my phone, so it is also useless. Is there another application that can be used to control this watch? I am guessing I cannot put the previous firmware back on it.

try factory data reset, with auto restore and back up my data off

Having the same issue after upgrade, please LMK if you were able to resolve

OK…good news! I figured it out!! Apparently they added a task killer in the upgrade. Go to “Settings” then “More” , then “Background cleaner.” There is a setting there called “Battery Saver” that turns off apps running in the background when the screen is off. Turn that off. I turned it off last night and just woke up, and my watch has not disconnected since. As a bonus, the Screen On gesture feature that turns the display on when you raise your wrist seems to work a lot better. Lemfo just needs to tweak this battery saver feature a bit I would say!!

Jan 6, 2019 12:47:56 GMT 1 cranstonsnord said:
OK…good news! I figured it out!! Apparently they added a task killer in the upgrade. Go to “Settings” then “More” , then “Background cleaner.” There is a setting there called “Battery Saver” that turns off apps running in the background when the screen is off. Turn that off. I turned it off last night and just woke up, and my watch has not disconnected since. As a bonus, the Screen On gesture feature that turns the display on when you raise your wrist seems to work a lot better. Lemfo just needs to tweak this battery saver feature a bit I would say!!



Aha… Thank you. Wondered why my battery was lasting so well, my background apps were switched off!

I was considering a post to see if any others had seen a marked improvement in battery life… Now I know why.

Well Done Cranstonsnord 

This seems like a good idea, but unfortunately it is shutting down something it shouldn’t. Maybe they will fix it on the next update, but I may not be brave enough to install any more lol.

Yes found it too, works great thanks!

Jan 6, 2019 12:47:56 GMT 1 cranstonsnord said:
OK…good news! I figured it out!! Apparently they added a task killer in the upgrade. Go to “Settings” then “More” , then “Background cleaner.” There is a setting there called “Battery Saver” that turns off apps running in the background when the screen is off. Turn that off. I turned it off last night and just woke up, and my watch has not disconnected since. As a bonus, the Screen On gesture feature that turns the display on when you raise your wrist seems to work a lot better. Lemfo just needs to tweak this battery saver feature a bit I would say!!


so with this task killer turning  off,even using Wiiwatch 2 did you get the screen on and notifications, i didnt update for this reason. i will try.
Jan 7, 2019 17:01:08 GMT 1 leafar said:

Jan 6, 2019 12:47:56 GMT 1 cranstonsnord said:
OK…good news! I figured it out!! Apparently they added a task killer in the upgrade. Go to “Settings” then “More” , then “Background cleaner.” There is a setting there called “Battery Saver” that turns off apps running in the background when the screen is off. Turn that off. I turned it off last night and just woke up, and my watch has not disconnected since. As a bonus, the Screen On gesture feature that turns the display on when you raise your wrist seems to work a lot better. Lemfo just needs to tweak this battery saver feature a bit I would say!!


so with this task killer turning  off,even using Wiiwatch 2 did you get the screen on and notifications, i didnt update for this reason. i will try.

     

       While I was trying to resolve the problem, I temporarily installed Wii Watch 2 on my phone and got some notifications. I used an iPhone up until a few weeks ago and that app did not work very well with it, and does not seem to work well on my LG V40. I do not think the Lemx update stopped the notifications. I was under the impression it was caused a change in the Google Store policy, having something to do with application permissions. Watch Droid 9 works great on Android devices, and if  you update it to version 10, apparently you can kiss your notifications for calls and texts on your phone goodbye. Unfortunately for you, your only option on the iPhone is Wii Watch 2. You may want to investigate that further before you upgrade. Remember, if it is not broken, do not try to fix it!  ;p)