Macrodroid on Prime 2

Has anyone else tried to use Macrodroid on Prime 2 ?

It seems almost any macro I try to create makes Macrodroid crash while I setup the macro…

Looks like there might be a bug in our Android 10 implementation, at least this is what Macrodroid support seems to conclude. Here is their reply to my bug report:

"I can see the crash and it’s coming from the android framework within the operating system. It looks like there is something dodgy in the OS implementation that is causing this crash I’m afraid. This is the only device that this crash happens on and I can also see other crashes coming from this device that happen on no others.

I assume you are sideloading MacroDroid onto this device and as such I cannot offer any solution I’m afraid.


@pablo11 what is the way forward with this ?


I’d like to have this resolved as well. I use Macrodroid to toggle wifi and data on/off based on the applications I launch. I installed Macrodroid on my Prime 2 and Lem12 Pro, when I go to create a new macro and click on “application list”, Macrodroid crashes back to its main page. I contacted the developer and after some back and forth emails and sending them the debug logs, they found out I was on a watch platform and stoped responding. I also tried to export/import my working macros from my Prime 1 watch to Prime 2. the Import took fine and the macros displayed in the application but did not trigger any events.


We managed to use MACRODROID on PRIME2.
I installed an old version (4.9.6) and imported the required macros. (airplane mode on-off, wifi on-off, SSID detect, call name talker and more)
With the old version all work and some can be edited.
A new one could not be created, but macros created and imported on another device (PRIME1) all work.

1 Like