Lem12 Pro Notification Sounds

I originally mentioned this issue in the Z32 Firmware thread. I have now come to the conclusion that this issue is a LEMFO issue, hence I am posting here in this thread. I am using the watch as a stand alone device with sim and NO BT connection to phone. All of the steps below resulted with the same result: no notification sounds for text messages received.

  1. Brand new LEM12 Pro flashed with A32 Firmware out of the box, never ran OEM firmware. Reset before watch set up.
  2. Reset watch again w/Z32 firmware.
  3. Flashed OEM firmware (v06_20201102) and reset watch.

My search in these forums shows this issue has existed with previous LEMFO models but when connected via BT to phone. There was no mention of the issue when using as a stand alone device. Am I the only one experiencing this? If so what setting would not be set with a watch reset?

@pablo11 I think you were going to check with Wiiteer but if I read the post correctly, it was assuming the watch was connected via BT to phone. I wanted to clarify my issue.

I really like this watch with the Z32 firmware but the lack of text notification sounds is becoming more annoying as my watch dependency increases. Thanks in advance for any assistance.

EDIT: Corrected A32 firmware to Z32 firmward

It’s definitely a problem, even stand alone - for launcher messages from system .

We are looking into this because all messages from the launcher seem to have no sound.

Messages from apps are ok.
But tethering turns the notifications in to system notifications…

We are looking into it :+1:


Just to provide closure to those with a similar issue, the latest version of the Unbranded FAW firmware fixes my issue with notifications.

If you haven’t tried it and rely on Google services in your day to day, try this firmware.