Kospet Prime 2 TTS engine problem

I have the language file in the watch and when Google assistant talk it’s ok. But when i install app like this : https://play.google.com/store/apps/details?id=com.ocelot.notifyier 2 the app doesnt work and say problem with TTS engine on your phone. I have try 4 différent apps like this, same problem…
I have try full reset of the watch and reinstall official Google Speech TTS from Playstore but still doesnt work. None of the apps can use TTS engine on this watch for by example saying the messages or notifications.

I suggest
after a factory reset, install the TTs engine.
Enable play store google updates.
Restart after upgrade.
Check the play store for google updates.
If there are no more updates, check the TTS engine settings.
Do not install any other program until the TTS engine is working properly.
If it works
check the tts engine after each installed program.
we have to find the fault. It just doesn’t seem to want to work for you. It works for everyone who wants to use it but not you.

It just doesn’t seem to want to work for you. It works for everyone who wants to use it but not you : Do you mean that app like this :https://play.google.com/store/apps/details?id=com.pelix.notify&gl=FR work on your Kospet Prime 2 ?

I do not know. I am thinking that one of the applications is interfering with the proper operation. That’s why I wrote factory setting + TTS engine and nothing else. This should work. If this works then you can find out what is going wrong. If you use the install-check-install-check method to find out which application is causing the error.

Have reset watch for the third time and just install Google speech TTS engine from PlayStore and nothing else, trying to use the app i mention before, same problem : doesnt work, error with the TTS engine on your phone… All other apps who do the same : read aloud messages or notifications, doesnt work because they cannot acces the correct TTS engine. I think this is related to the firmware of the watch or maybe an Android 10 problem. Could you please try https://play.google.com/store/apps/details?id=com.pelix.notify&gl=FR because i’m sure you will get the same result and see the bug… Best regards and better 2021.

Watch this video. I set the watch to French. Believe me, the watch is okay. I can’t try the app. It does not support the Hungarian language. Therefore, it does not appear in the play store list.

1 Like

what language are you installing on google tts? French? Have you tried english?

Yes i have try English at first : same problem.

Well when i see that i’m jealous. I’have try full reset the watch again and dont put any other apps except Google TTS engine, let it in English, when i go on this screen you have ( TTS engine Test ) the play button is grayed ( cannot test ) and after set my language ( French) i obtain a ’ force close ’ when i go in TTS engine… I’m tired by this bug now and have retake my old Lemfo Lem T who doesnt have this problem. Thanks for your effort and happy new year.

The next idea

then check for play store updates
enable goggle updates
restart and then test

Even i do that and play store updates : no more succes… Do you think i can flash the whole firmware and how do that ? Thanks.

something is strange. I’m sorry u cant get it to work on yours

1 Like
1 Like

Yes as you say very strange bug and i have also some other problems with this watch : notifications from apps works during only 1 hour and after that they stop (need to reboot the watch to get them again) and i cannot send messages (sms) to some of my contacts… I practice mainy watchphones since 10 years and never see that on a watchphone. i’ll try to flash her firmware when i get time, so follow… Thanks again.

1 Like

Thanks a lot, but i cannot Flash : error in flash Tool when i open the ’ scatter file ’ where is the correct scatter file in the firmware ?

The IMAGE folder contains the only txt file.
I just tested it. Works well. If it doesn’t work for you, there is a problem with the download or unpacking. Unpack or re-download and unpack again.

Ok thanks, i’ll retry.

The firmware is load now ok in Flash Tool but when i plug the watch it is not recognised, bad driver ? i’m on windows 7 64b…

Flashtool not recognized? Flashtool only recognizes a watch that is off.

Hello, this is the watch who is not recognize on my computer Win 7 64 b and yes i plug it off when i use FlashTool.