Kospet Prime 2 Official support UPDATED!

We can’t do anything if they decide to lock their preloader.
Sorry but I’m not sure what you think we should do?
We can’t tell them what to do…

In 2.1 some app doesnt work well.
In yourube I want to go library section on square mode no reaction when I tap. In round mode I can’t get to library because buttons are out of the screen.
Battery life is not bad.
Missing tap to wake function is really upsetting
Original firmware still need a lot of fix to be better than faw

@pablo11 My current kospet prime 2 version is stock v2. 1 can I update this Faw prime version directly.

Bluetooth pairing issue with my phones and battery draining problems are there.

Thanks in advance
Mahesh B

Which FAW version are you talking about?
Can you show me a link to it?

Hi Pablo,

I am refering this version which I got from older post


Mahesh B

The answer is no.
But also see this


Thanks for reply.

Mahesh B

1 Like

After that @ pablo11 closed all threads, I’m afraid to write about my problems, but where else can I get help if not here …

The situation is as follows (my device is Kospet Prime 2):

  1. I had the FAW_v1.2 software installed
  2. Then I installed FAW 1.3-B4 and started Universal Luncher which caused the watch to go into death loop with a message that Universal Luncher is still stopping.
  3. With FlashTools, I have successfully installed the D09 firmware.
  4. Then I installed FAW_v1.0 successfully.
  5. The next step was to install FAV_v1.2.

After every firmware upload, I did a factory reset.

After all these operations, I noticed that my Kospet, when connected to a computer, is not recognized by Windows as a USB device (I checked it on 3 different computers using two original cables), although it was always there before.
What’s worse, Flash Tools also does not recognize and does not load the D09 stock firmware.
Attempting to install FAW_1.3-B4 or reinstall FAW_v1.2 also fails.

I apologize for my English but I hope you understood something that I wrote with the help of Uncle Google :slight_smile:

Please try to install the stockfirmware with the flashtool: use “firmware update” option, connect your watch to the PC. After that, press and hold both buttons to start the flashing process.

Yes, thanks @G1NT0N1C exactly right.
@pokahontas Flashing the stock firmware is all that is needed. :+1::+1:
Don’t to be scared to ask for help. :ok_hand:

By the way, USB settings need to be set to “file transfer” when you are using FAW firmware. Going to Settings, Connected Devices and clicking on USB will show the menu. This is stock Android 10 behaviour.

Anyway, about flashing stock firmware.

Use these tools and make sure to use the driver package included.
Try a different USB port if you have any problems.
Make sure you are using the correct USB cable that came with your watch. Other watch USB cables are not the same.

And flash this firmware version.

1 Like

I have the FAW 1.1 installed on my Lem 12 Pro and it’s way better than the stock ROM. Much better battery life and less bloatware. I’ve had no issue whatsoever until now. (I had the 1.2 installed previously but it had an issue with the lift to wake so I switched back to the 1.1)

@pablo11 & @G1NT0N1C Thanks for the quick replies.

  1. I have two cables, one bought with the watch and the other one bought from the official Kospet store.

  2. I have “file transfer” USB mode enabled.

  3. I have used Flash_Tool successfully more than once.

  4. I tried Flash_Tools on three different computers before installing the drivers included in Flash_tools.zip

Unfortunately, I will not be able to connect to the watch. After connecting the cable to the USB port, the watch starts to charge, but it is not recognized by Windows in any way.

I wonder if I could somehow damage the USB port, e.g. by wrong connection / disconnection of the cable.

Have you tried to start the flash process by press and hold both buttons?

Yes, the flash process does not start. The Chinese menu appears.

Ok, please wait until the battery is completely emty. Then flashing should be possible by using the option “firmware update”.

Ok, I’ll wait and let me know if it worked :slight_smile:

To give yourself enough time to flash when the battery is empty keep trying to power on until its completey dead . If not it will reboot and wont work

If the Chinese menu appears it is going into stock recovery by using the multiple button press boot.

So you have installed the drivers again?
Sometimes windows will get an update and the driver is overwritten.

You can test it by opening device manager and watch the com port section.
With the watch powered off - when you connect to the pc you should see the port enabled temporarily.

If it is not then reinstall the drivers from the tools zip…

See the MTK vcom port in this photo.

I think the driver is installed correctly. I have a second watch (also Kospet Prime 2) in which the flashing process is correct (it does not even need to press two buttons simultaneously).

I have discharged the battery and Flash_tools still does not see the watch and the flashing process does not start. In addition, after connecting the watch to the charger, it does not start to charge either.

Previously, before the battery was discharged, the watch was not visible via the USB port, but at least charging was working properly.


You don’t have to press any button to start the flash process with emty battery. Prepare the flashtool (choose the stockfirmware scatter file, choose firmware update, then click download).
Then connect your completly emty watch with the (original) cable. At last, plug the cable to the USB port of your computer.
This procedure normaly works as a emergency exit.

1 Like