Kospet Prime 2 Official support UPDATED!

One more thing - some 3rd party apps (such as Button Mapper and recently Mi Fit) do not create an icon on the app screen after installation and I have to open them via settings - applications. Can I create my own icons for apps? Is it possible to create a “frequently used apps” screen?

Update: @noidremained, I followed those steps in your video and even paid for the pro version (as my only option to map to is the back button) but every time I close the app, after a few minutes the screenshot mapping stops working and I have to go back into the app and follow those steps again. This is obviously a rather tedious way to take a screenshot. Any idea why this could be happening? Seems like the OS is killing the app once I switch out of it.

Hi . No you cannot create your own icons with this launcher . It does sound like the app is going to sleep

In settings make sure the app is " not optimized " and has " unlimited data access " . It then will run in the background

Have you tried the updated FAW international version yet?
You can just drop it on your watch storage and use the Wireless Update app in the “About Watch” section in Settings.

In this version of firmware you can access these settings on every app as the settings are stock Android 10 settings. Like allow to run in the background etc …

1 Like

Wrong thread - feedback in the other thread please

Tried both of of those settings but it still happens. Anything else it could be?

@Benson_Wallace check this out

All recent apps are closing when locking the device - Kospet Products / Kospet Prime 2 - Full Android Watch

Thanks, that seems to have done the trick with button mapper (and I assume it will solve my “apps disappearing from recent apps list” problem too).

Has anyone else tried to install Google Translate?

We have tested it on our version and it is working

1 Like

This is what happens when I try to open it:

Ok, but are you using the v2.1 stock branded firmware or the FAW international firmware…?

If you are using stock firmware this is a known issue for a long time.

v2.1 stock. As I explained in another thread, I’m hesitant to try the FAW international firmware right now. That’s cool, I can translate through Google Assistant for now and see what the next OTA brings :slight_smile:

Yeah, that’s the reason why I asked.
It is a known bug in the stock firmware.
A lot of google apps have issues with the stock firmware due to the many embedded Chinese configurations for internet access and other things.

It’s one of the reasons that some countries are banning these devices… All broadcast traffic seems to be routed through a Chinese service.
Anyway, all good.
It’s just how they work and it’s necessary for them…but unfortunately does not work so well for people outside of China.

It is also one of the reasons why they joined up with us to try and present a choice of firmware.


Me personally couldn’t use my bank app cause it says it’s not safe to use app on this device aftwr faw update everything was fine


Exactly what I was talking about.

I installed settings search but the display size is missing.

Is this because I’m on the international FAW firmware?

So you don’t have display settings / font size…?


I have font size, but not display size, as per this picture you posted:

What does scale app do? Cause I don’t see it in my display settings

That is because you don’t have it and you are asking in the wrong thread.
It is in a beta version of the FAW international firmware that I will post in the correct thread soon.

I posted that picture to show font size.
That’s all


Starting today, when I try to open the stock Camera app I keep getting an error message: “Camera Error; Can’t connect to the camera.” Previously it had been working fine. I am using FAW 1.1 firmware but I’ve had that installed for a few weeks and the camera was working fine until today. I’ve tried force-stopping the camera app and re-booting. Does anyone have an idea how to fix this or what might be causing it?

Note: I previously posted this with a new topic, but then figured this is the better thread to post it at, so I requested deletion of the other one.