How to root the X7?

I want to use Xposed, do I always need TWRP?
How can I root the X7 with 7.1.1?

(This text is needed because of the minimal character limit…)

1 Like


No? not possible…

yes, it should be possible to root it. You don’t need twrp in order to root it, but you will need twrp in order to install xposed. It doesn’t look like twrp is available for the x7 yet, but if you want I can port it for you

1 Like

That would be wonderful. In my optinion it should be no big difference to Lemfo and the others (even the cases seem most from the same factory)

By the way, xposed with xposed edge is nice, because you can set gestures or functions on hardware keys. On some keyboards is the enter key (swype for example, great to write fast!) not reachable, so you can put the keyboard “enter” on double-click on a back-button.

Do you had success with the root?

I’ve ported it now (ported from this version: I’ve also included the zipfile for rooting with magisk in the download.

Just flash it with sp flash tools in download only mode, then after booting you can use the adb-command “adb reboot recovery” to reboot into twrp, then you can transfer and install the to get root.
You know how to install xposed after that, right? Let me know how it goes and/or if something is unclear

Thank you very much. Do you tested it with your X7?

After that, update is no more, right?

I haven’t got a X7 myself so I can’t test it, but the same procedure has worked fine for both my I8 and A4.
Yes, as far as I know, it won’t take OTAs any longer

Then I will have the same problem as with my X5+, how to unroot/un-twrp to get updates again?

shouldn’t be a big problem, just flash the stock boot and recovery from here: when you want to take an update

1 Like

Yep, take backup in recovery.
Flash back to stock boot and recovery.
Save backup to your computer.
Reset your X7 and take the OTA.
Flash back the TWRP recovery and patched boot and restore your backup.

1 Like

Had not much time lately, but used it now and it worked! Thank you very much! :grin::+1:

1 Like

Can someone make a step by step tutorail… I’m afraid I can brik my watch if I do something wrong, the only thing I wanna do is to kill boot and off annoying sounds

  1. copy the magisk zip to the watch
  2. disconnect the watch from the computer and turn it off
  3. open sp flash tools
  4. select the scatter file
  5. make sure the download scene is download only
  6. press download
  7. connect the watch
  8. wait for the green check mark to appear
  9. boot the watch
  10. use the adb command “adb reboot recovery” to boot into twrp
  11. choose install and then choose the magisk zip
  12. wait for magisk to finish installing and then reboot

Thanks I reached 10.

I have been hours looking for a working adb drivers for my old 32bit windows vista laptop… And noway, do someone have it? Can you please share with me, thanks.

I don’t know whether it will work with 32 bit vista, but here’s the official download:

Thanks for the help, I finally found an installer so I correctly installed the drivers… But looks like there is a problem with my kernell32.dll and I won’t format that old laptop… So, I won’t kill annoying sounds.

well, there are other ways to go on to root it, you can try this:

  • copy the boot image to the watch
  • flash it again, but use the twrp image for both recovery and boot partitions
  • turn on the watch (it will now automatically boot into twrp)
  • choose install, then install image and choose the boot image
  • as target partition select boot and press the check mark
  • when it’s finished you can go to the home screen again
  • then select install again and this time install zip and selct the magisk zip
  • then, when magisk is installed, reboot to system
1 Like