Hi all, I'm using sinwear (or wiiwear,

Hi all, I’m using sinwear (or wiiwear, tried both) with KW88 (Last firmware) and my iPhone 5S (Last iOS) .First connection is ok with the app, It shows a pin and it asks to insert it into the watch and I receive notifications correctly. The problem is when the connection is lost, if a re-open the app in order to reconnect, It asks to insert a newer code into the watch. Anyone here knows this strange behaviour and can help me? Pairing each time is terrible! Is there an alternative iOS app to sinwear? Thank You!

Same issue here watch software is a pile of crap

I really tried everything , I found other pair apps: “BT Swatch”, “Konnect”, “Mediatek SmartDevice”, nothing, it seems like they’re only a tool to pair the iPhone with the watch and so they work exactly at the same way. Another annoying thing is also when It’s paired WhatsApp notifications don’t display the name of the sender, just the message and it’s quite useless! Hope in an update soon but as far as I saw , iOS is not considered a lot, so sad!