Hi all, Has anyone ever been able to figure out how to fix the

Hi all,

Has anyone ever been able to figure out how to fix the GPS issue?
I have already tried some solutions out there, and all kinds of settings combinations (Wi-Fi on/off, location services on/off, etc.).
Following one of those tutorials (using GPS Test, FasterGPS and MTK EPO GPS Fixer), I was able to have a fix with very strong signal, even indoors. But unfortunately it didn’t last too long. After a few minutes it lost the signal and I had to go through all the steps again.
But I guess the experience was enough to indicate it’s not a hardware problem, but rather a bad configuration made by the manufacturers that assume MTK GPS hardware is not good, as stated in one tutorial on XDA, that claims to have the ultimate solution. That guide uses ADB, system files mount and messing with some xml. As a noob I am, I was hoping there were a simpler solution for it, using a couple of apps. But if you guys (that understand a way more than I do about GPS, EPO, satellites, etc.), say that this solution could actually fix the issue, I’d definitely leave my laziness aside and give it a try =)

Note: I’m trying to use the GPS as a standalone watch (with a 3G SIM card inserted). But also tried using the phone’s internet shared over Bluetooth.

So, please, any light on this would be much appreciated.


Hi @Alessandro_Domingos ​, try it outside under good weather/ sunshine. It will work. Most of us try it inside room. It will not work because the gps antenna is so small. I use kw88 smartwatch.

Hi @akhmad_kai ​, thanks a lot for you reply!
I have tried it several times outside, while running. Unfortunately only a very few times I got a GPS lock.
Runkeeper works pretty well on my D5, but it’s useless without the GPS.
Thanks anyway =)