HI all... Finally got my watch.

HI all…
Finally got my watch.
Is there any way to disable the ‘Link Loss’ feature/Alarm on the stock watch? Pretty much driving me crazy every time I walk away from my phone. Worst part, it does not shut itself off.

You are not the first to ask this and yes it is annoying !! Even worse is the fact that the developer gave no option to disable it.
If you have root access my advice would be to go into the application install directory and remove the sound file or rename it to something the app can’t use.
Only do this if you are very familiar with browsing and altering Android file systems - you could do some damage otherwise.

Was not sure if Loki’s rom fixed it or not. You would have to root both the watch and the phone as it pops up on both. Ugggggh

i think the alert does actually stop after a (long) while. I remeber going to the bathroom (too much detail) alert started on my watch which I swipd away, and by the time I got back to my desk where the phone was, it had stopped there.

LOL thanks for the TMI @Andy_Godber and if you were at work the whole team knows you bathroom schedule. haha

So I am starting to think about not using as companion either. Can’t get consistent notifications anyway. Sadly, when I put my T-mobile SIM card in I get the message text warning on my account that says “ineligible device…” not sure what that means. Yes I know that 3g does not work, but was willing to settle for 2g…and now that seems flawed. Guess it’s Wireless connection for me.

T-mobile Nano SIM from my GEAR S (4g, 3g, 2g) would assume it’s the same as Gear S for calls etc.
LOL I installed your rom and lost my IMEI # in the process. Shows NULL now. No telling what I did…hahah

Happened when I was trying to Root. No did not make a backup. Do have the IMEI number though.

It may sound strange that I’d like to have a notification about lost connection, but I don’t have it! (??)
From time to time, the watch loses the connection and sometimes reconnect by itself, and sometimes not. Then I have to do Push Reset and (sometimes) it reconnect. If not, I have to initiate connection from my phone.
There is also another situation: BT connection is ok, but notifications a not active (Watch Helper > IOS > Connect BT is disabled). Push Reset sometimes help.
All in all, lots of “sometimes” and notifications are not consistent and reliable.
That’s why “Link loss” is one of the important features to me, so I don’t forget my phone somewhere and I want to be sure that I have connection and notifications will be delivered.
Any ideas how to activate it? Or is there a program that can replace that function?
I have iPhone 6 and rooted D5 on W812a v1.2.0, but everything worked the same with factory settings.
Am I doing something wrong?
One more thing: is it normal that I can connect to watch even when BT is turned off?? Everthing works (when it works) ok, I didn’t find any differences in functionality between BT turned on or off.