Hi All, Can you please help me? I've just got my Finow X1.

Hi All,
Can you please help me? I’ve just got my Finow X1. Great watch by the way!

I pressed the default face watch and hovered the screen to get new watch faces. I stumbled into a blank face watch and tried to press the (-) minus button to delete a blank face. Instead of deleted it, the watch selected it. Now, I have a blank screen watch. I cannot do anything. Nothing works. It boots normally and then displays a blank black screen.

How can I fix my watch please? It’s just 1 day since I got it and I am going nuts.

Thanks in advance

P.S: Since I posted this problem, I tried flashing the watch after looking at the Youtube posts. Now, the watch is not even switching on and the Windows is not recognizing the USB driver when I connect the watch.

Oh my!! It looks like it’s going in the bin.


Hi JN… there have been (and will continue to be) many posts on similar subjects… try using the “search” bar, I’m sure you’ll find something… :slight_smile:

Take the back off the watch and disconnect the battery cable. Re-connect after around 30 seconds and turn it on. If you don’t know which one is the battery cable - search for it - in here or on google.
You don’t really give us anything to go on.
What firmware did you flash?
Was it successful ?
Please give us something to work with…

Hi Pablo. Thanks for the reply. I managed to fix it with the help of this comminity and the youtube videos. You folks are great. Thanks

good to hear :slight_smile: