Hey guys i need you're help with my d5 i hope this is the

Hey guys i need you’re help with my d5 i hope this is the right section but the thing i need help with is i updated my firmware today and after i rebooted my watch i saw it was not loading my watch face (black screen) the ismenu the only thing responsive so i can still adjust teh brightness and turn of the watch i hope you guys can help

Er…Did you notice the announcement,alright since you have updated,like Lokifish said, you may flash older firmware to get a functional watch back.

I’m watching (and rewatching) the SmartWatchTicks video… and have downloaded the old firmware… now to install :slight_smile:

ah thanks dude i did not read the announcement i have to use flash_tool right ? are there any tutorials on how to do that for the d5 ? @Will_Smith

you can find it on our forum.or NO.1 official website.(there is a course)

Windows 10 64bit… downloaded the zip (with three folders)…managed to load the USB drivers (found that I needed to use compatibility mode - didn’t see this in the guides)… clicked flash_tool.exe but can’t seem to get past, “The scatter file cannot be found”… :frowning:

usb compatibility mode? It’s right that on the settings.

@Will_Smith Vista compatibility mode…

Found something.but not windows 10

Phew!.. I’m up and running again… :slight_smile:

How is everybody else?

@Andrew_Davis had to flash my watch this week too, wouldn’t load the battery… Had to try the sptool for about 10 times, each with a different error and was nearly ready to give up - then it just plain worked… Now I got at least my watch back, still no time to toy around with faces atm…

@Haggis_Tanaka It was a real pain… but what doesn’t kill you, makes you stronger :slight_smile:

Bro if the menu option is accesible…let your watch’s battery drain then plug charger and remove it…battery is low message appears…select ‘battery use’ and then launcher and clear its data…done.

@Shubh_Shah Good tip :slight_smile: … but I only had, "the “black screen of death”…