Got the X3+ from GB. Portland, OR with T-mobile SIM: 3G instantly. Data=good, calls=good.

Got the X3+ from GB. Portland, OR with T-mobile SIM: 3G instantly. Data=good, calls=good.

I tried using the watch as standalone and left my phone at home (moved the SIM to the watch) Google Hangouts doesn’t update, i.e. Google Sync isn’t working, unless I’m on Wifi.

I am clearly getting data, I can use a browser. And Hangouts does update, but only if I have the app open an active for quite awhile.

I tried some “Push Fixers” to change the mobile heartbeat, but that didn’t seem to do anything.

Does anyone know how to make this work?

(the watch faces are beautiful, btw folks)

I’ve noticed it too. I’m going to have to talk to Finow about this

I’m seeing the same on my No. 1 D5 with my Project Fi data only sim. Play Store works but Hangouts reports no internet connection. Google Inbox seems to work as well (slowly).

I think I have found a workaround until we get it fixed.
If you manually disable WiFi in settings hangouts works fine. Data switching (an old enemy) seems to be the culprit.
The watch cannot determine that WiFi is no longer available and looks to it as the only source of data. Until it is disabled.
Test and let me know.

I tired manually disabling WiFi and that seemed to have no effect. I sent myself some hangouts messages and some Gmail: nada on the watch.

So then as an experiment, I had the watch make a WiFi hotspot for my tablet. When I sent an email to myself, I got the notification on my tablet, but the watch never notified. Not until I opened the hagouts/gmail apps, did it download the messages.

Maybe I am missing some Google service on the watch?

I also have wifi disabled and see the same issue with Google apps. I tried the hotspot from the watch and it was too slow to search Google. Maybe I’m just in a bad spot for the signal, so I’ll try other spots.

That is odd. I receive hangouts messages without issue. I will try again…

I take that back. Tested and double tested - it does not auto update. I will feed this back to Finow

Today I went for a drive and turned on the wifi hotspot on the watch so that my tablet could get data for driving directions. Worked flawlessly and I was getting gmail/hangouts updates on the tablet.

Nothing from the watch though.

How will this be resolved; thought OTA update?

I have a meeting with them tonight - Australian time - I’ll see what can be done…