FINOW X1 Firmware 160414 A couple of things I've noticed.

FINOW X1 Firmware 160414

A couple of things I’ve noticed. The rotation direction fix is there, and it’s the same as the D5.

The watch chimes when you connect and disconnect to the charing dock no matter what your sound setting is on the watch.

Anyone notice anything else that has changed?

We are waiting for the Imperivm v1.2.0 :slight_smile:

Can I install also on D5 ???

If this firmware fix phone radio issue, can I flash only the new baseband file ?

And every one have the same issue ?

Bad news then… It’s pity :frowning:

I will test as soon as possible and feedabck

Loki, What about X5 Finow watch firmware? It appears on videos more updated that rest…

I’m just about to flash. Do you mean heads Up doesn’t work or the stock notification system ?

I’ve tried it - it will not work on these watches - only X5.

@SmartWatch_Ticks Where did this firmware come from ?

This is probably just me but -
As soon as I flashed this my watch died :slight_smile:
I had to disconnect battery - no good - would not turn on.
Then I started getting USB power surge errors … :frowning:
I finally got it back after shorting some pins etc etc …
I’m guessing it’s just my problem though as I see no other comments like this.
I’ll keep trying but as yet still have not managed to flash this new version…

For the phone bug I have partially solved the problem using “signal care” app.
In the app I’ve set a automatic radio refresh every 15 min, and this seems can reset the radio freeze.
In the app you can select also automatic radio refresh, based on signal strengh, but this setting don’t works because when the radio freeze, the signal indicator also freeze.
This is not an ideal solution, but surely the phone will receive call 15 min after every lock…

Yeah, but basically it still means the firmware is buggy as Hell…!!

It’s odd indeed. No matter what I do I cannot flash this firmware and successfully boot the watch. I guess I could swap out the boot image, recovery and UBOOT file but I have to wonder why this is?
It flashes without error but I cannot power on the watch afterwards !! Always have to flash back to D5 stock to get it back.

@Lokifish_Marz @SmartWatch_Ticks

Hi guys, I thought I’d share what happened when I finally managed to update my K8-Mini with the latest X1 firmware you gave us.
It was the first firmware I could not flash as it was presented.
I had to leave the pre-loader unchecked and use the “download” option in SPF tool.
I normally use all items checked and choose the “firmware upgrade” option for a completely clean start - but that ended up with my watch not booting at all - very strange.
Anyways - once I had it flashed and had factory re-set it I proceeded to attempt to set up Google with 2G only to test the radio band bug.
I can’t tell you how surprised I was when it actually worked and I managed to completely set it up with no other network options except 2G. Even downloading apps from the market with no problems.
I will leave it like this for a few days to monitor battery performance - but what a surprise !! :slight_smile:

Whew! That’s great to hear. I remember from watching a couple of videos where they said to not check extra boxes and use the Download option only. Not knowing any better, that’s what I stressed when I did the firmware flashing videos. I’ve been on pins and needles wondering if I screwed something up in the firmware download or in the process in the videos or whatever and would have a lot of folks in the same state as you were. Thanks for clearing this up (not that I understand yet, but it sounds good). The firmware came from Jessie of FINOW as an email attachment. She also sent me a new X5 firmware which is what I flashed in the video for that watch. It’s 160414. Do you have that one, or do you need/want it? I also have 160407.

I was totally surprised when this new stock X1 firmware worked with 2G sync !! Like I say - only thing I might have done differently is that I did not select pre-loader when I flashed it.

Yep - no notification except sound when you receive a txt - confirmed.

Please let me know if this firmware solve the radio bug, that freeze the phone when you went to uncovered area