**FAW release candidate 1 v1.3**

Releasing our update.zip International Firmware here

10 Likes

Please read carefully.

UPDATE - LEM15 / Lokmat APPLLP-4 is now available again - with warnings - so please read the notes in the download section carefully!!

NOTE to access the downloads you have to be a member of this forum - this will not change !
A very small amount of technical knowledge is required to use this and if you are unsure - please read up and feel confident before you start.
It is assumed that you know what you are doing when you are using the “built-in” Wireless Update app to flash a “local update.zip” However, I have included some simple instructions further down.

This is the Release Candidate for the collaboration between FAW and the Solution Providers in China - Wiiteer.

Our agreement with them is this - and we will not be changing it:

1. To provide a firmware for international users who are using Google apps and syncing their Google data.

2. To remove or replace Chinese web dependencies that were in the stock firmware (due to the great firewall)

3. To get the best battery life possible by removing custom apps and those “just make it work” solutions.

4. Improve security

5. Allow Android to work as it should, without pointless task killers and similar. Battery life is significantly improved this way.

Please don’t ask for additional features unless we announce that we will consider them!
For third party apps like Universal Launcher there may be tweaking needed and we will be working with @Eric_Crochemore to try and fix issues if they arise.
Other Third party apps - it will be best effort support and difficult because they are closed source.

First and foremost, this is about achieving a stable, Google based Android 10 OS.
After the Beta program - we think this Release Candidate is a good start.
We hope that you will have a little patience while trying this update - it may not be suitable for everyone.
Remember - we do this for free and in our spare time because we want a better standard FW for International users of Full Android Watches.

Wiiteer and FAW have spent a long time overcoming the remote working challenges to achieve this.

Currently this is ONLY for the following Android 10 models:
LEM12 Pro/APPLLP2
LEM14/Rogbid Brave Pro *
LEM15/APPLLP4
Prime 2/APPLLP Pro
Optimus 2

Note* Rogbid Pro is reported to work but we cannot test it because we don’t support it - users with this model report it is fine.
More may be added to the list as we see what is released in future.

Using this FW - more about this in the download section
Download and copy the correct zip file (do not extract) to your watch storage.
Go to watch settings and select “about watch”
Select the “Wireless Update” app and using the three dot menu at the top - select “internal update”
Navigate to the zip file you have downloaded and transferred to the watch storage and select it.

At this point your watch will tell you it is checking the file and will reboot to complete the update.
Once reboot is complete - IT IS STRONGLY RECOMMENDED THAT YOU MAKE A FULL FACTORY RESET!!
This will ensure that no mistakes have been left behind from the previous installation.
You should be on stock firmware before you first do this to prevent unexpected issues
You will be able to use future update zips without flashing back to stock!!

If you get a failed update - it may be that your stock pre-loader was different to the one used to make the International firmware.
For example - LEM15 FAW update may fail on Lokmat APPLLP 4 due to different pre-loader and signature - even though they are the same watch.
We are looking at this but basically if you have this issue you can use SP flash tools in “firmware upgrade” mode to flash the stock Lem15 FW in FW upgrade mode to your Lokmat APPLLP 4 and then this error should be resolved.

The same is true for the LEM14 and Brave Pro and the LEM12 and Lokmat APPLLP 2 and also the Prime 2 and Lokmat APPLLP Pro.

If, at any point you decide to go back to the stock firmware - you will HAVE to use SP Flash Tools to flash the full version for your watch

To download visit the download section which is a seperate category and only FAW site members can see it.

16 Likes

This FW update is offered on the premice that you know what you are doing!!
Understand that due to issues beyond our control - we are not available to answer “how do I do this” questions.
I have had to visit friends just to post this.
My stuff is currently unusable due to floods.
The reason why this is restricted to Level one users (have to have made at least a few posts and read some stuff) is to try and help prevent impatient people trying it and failing.
Take your time please.

If you post nonsense here it will just be deleted.

18 Likes

After upgrading to the new FAW international firmware, the pedometer indicates like


in the picture. Can it be reset?

1 Like

Have you tried a factory reset?

No, but I will.

Please perform a factory reset before asking about problems.

And please don’t post questions about FAW firmware in regular support threads.

Cheers

5 Likes

Just to answer the PMs that have been sent to me about access to downloads:
To become trust level 1 - from the discourse FAQ.

Get to trust level 1 by…

  • Entering at least 5 topics
  • Reading at least 30 posts
  • Spend a total of 10 minutes reading posts
3 Likes

Becoming level 1.

This is designed to help you.
It is important that you understand what is going on when you choose to use the FAW firmware.

You need to be ON STOCK FIRMWARE for the first time you use it.
Further updates, if issued, will be able to be flashed from the version of FAW you are using - after you have used RC1.

To go back to stock you HAVE TO USE FLASH TOOLS.

I hope this helps.

6 Likes

@charliest
You can’t update from a previous FAW version.
That’s why I said in the first post - and the post above this one - make sure you are on Stock Firmware before you use this.

So you have to flash stock firmware with SP Flash Tools.

3 Likes

@charliest
Please stop sending me PMs.
I have kindly asked you to use this thread for questions regarding FAW firmware.

If you don’t understand the basics of flashing firmware with SP Flash Tools - there are many posts here on the forum and videos etc…

All you have to do is use the search function at the top of the forum.
If you are getting a scatter file error then you either have the wrong stock firmware or you have extracted it to a folder that has spaces in the path.

Please read up on this.
I am trying to get my life back together and I can’t be answering these most basic questions when the answers are all here on the forum for you to read.

Cheers

4 Likes

Good morning, has anyone here tried this version on this watch, can you confirm that everything is working correctly like camera 3g / 4g gps… FAW release candidate v1.3 is better than the chinese one, as promised?

Yes. Give it a chance. If you don’t like it, you can switch back to your original firmware without any problems.

2 Likes

Sorry to bother you again, I’ll take advantage of it because I had some doubts. following @pablo11 make sure you are on Stock Firmware before you use this. so i have an original operating system (Kospet_optimus2_PIX_v1.7_20211201) and I can update directly with update.zip International Firmware and perform a factory reset. That’s all right. thanks

@charliest
This is your problem.
You have been a member for only 3 days.
So you need to go and have a look around the forum. Then you can reply to posts

1 Like

Hi Pablo 11 , I noticed something annoying, the sounds are disactivated… When I receive a call or a SMS, no sound… In the paramaters the mode " Do not disturb" Is activated and there is a comment which mentions this paramater can not be modified… It seems it worked fine when I got the watch… Any idea how to solve this problem ? Thanks

Quicksettings- quite mode off.

I kept on looking for and I found the solution, you have to go to " Limit notifications " and then select “customised” …

Thanks, I do not know this menu " Quick Settings ", how to get it ?

Why not searching before posting? Just swipe up from your watchface.