Custom watch face - blank screen problem.

Custom watch face - blank screen problem.
I remember reading that someone had downloaded a watch face that resulted in completely blank screen - cant get access to system or apps etc.
Well, its happened to me, but I cant remember the fix - please can someone remind me?

This has happened to me. Usually I connect to a pc and can get the usb storage connected. You can then take the clockskin folder out and put it back on. Usually works for me.

@Bob_G already tried the reboot - unsuccessful, so will connect up to PC and try deleting clocksin folder, later, as per @C_For

Hi AG… what/which skin were you trying to load onto your watch?

It was one that appeared on the inbuilt downloadable option - cant take a picture at the moment because its a blank screen :stuck_out_tongue_winking_eye: Will spend some time after work this evening fixing and trying again.

@Andy_Godber Okay… I just wondered if it was one of our custom skins that had caused the problem… :slight_smile:

If you can get to the launcher under the blank screen you need to get to the app management menu with settings search and wipe launcher cache. If you can’t get to this I’m sorry to say that re-flashing the watch is the only way out…

Here’s a video about what @Pablo_Eleven_Pablo11 is talking about:

@SmartWatch_Ticks thanks mate

My solution:
1.turn off middle and upper button until welcome text display and press the upper button
3. you will see a chinese menu, go to eMMC line with upper button and press the middle button
The cache will be reseted and all data, apps etc. deleted

@Lohner_Zoltan which watch are you using? Sounds like this only works for the FINOW X5 as it is the only one with three buttons.

Yes, I have a X5. I downloaded bad watchface with stock watchface browser. The screen was black, and didn’t respond any touch.
In other watch you can try wipe cache with adb shell.

@Lohner_Zoltan How does a newbie with nothing but a blank watch and only one button on the watch (D5/X1) wipe cache with an adb shell? This is a newbie now, with no computer experience. Can it be done by a novice?

I didn’t try it, but the following should be good:

Install driver:

Install adb.

Type: adb shell
Type: recovery --wipe_data (erase user data and cache, then reboot)
Type: recovery --wipe_cache (wipe cache but not user data, then reboot)

Last chance:
Type: adb shell am broadcast -a android.intent.action.MASTER_CLEAR (delete all)

if i may, did deleting and re-installing the clockskin folder worked? where can i find it?

Hi i done as you said but i cant see a chinese menu, so i can go to eMMC

I tried to use the trick with middle button + upper button, but I can’t get into the menu. When exactly do I push the upper button? When I see a little watch and the text “smart watch”? Or do I need to hold the two buttons longer? Or do you need to have a custom recovery for this trick to work?

Okay, so I found out what went wrong with Zoltan’s instructions. What worked for me:

  1. Shut down watch
  2. Turn on with holding middle button + upper button until you feel a strong vibration. Let go of the two buttons and wait. Then the Chinese menu appears and you can scroll to the EMC menu option with the upper button.
  3. Select the EMC menu option with the middle button (push just once!) and then do a lot of waiting.