Can anyone help with my no. 1 d5.

Can anyone help with my no. 1 d5. I recently copied several skins to a clockskin folder on my watch and all worked fine until I turned it off and now it won’t turn back on.

That’s weird… what happens when u charge it?

Similar happened me on my x5. It was black screen but the launcher (clockface part) wouldn’t work but if I swiped right it went to the other screens.

I couldn’t find a solution so I had to flash the firmware.

When I plug in to the charger nothing happens. Tried different cables etc but nothing. Just tried swiping right but nothing the screen just won’t turn on

try to open the back cover and detach the battery
and plug it back on
maybe leave it unplugged for a couple of minutes

@Shane_Nurdin yep - what @Momi_Az said and if that doesn’t work you will need to flash the firmware. Make sure you research it thoroughly before you do. SmartWatch Ticks has a couple of great You Tube vids on this and all the guides/files are here on the forum as well

I just had that happen to me, too. Fortunately I had floating toucher installed and the round dot was visible on the screen over where the watch face should have been. I also tried everything short of turning the watch off to get back to watch faces. Finally, when I tapped the dot I got my Floating Toucher overlay and on it I had access to the app Settings Search. I launched it and navigated to apps, then to launcher, then cleared the data. Watch restored after that.

This verifies that it a data corruption in the launcher, clearable and correctable by deleting launcher data, but without having that dot there I could not have gotten to the Settings Search app as touching the screen – or holding it – did nothing.

@SmartWatch_Ticks I don’t think his watch is even turning on.

How do you detach the battery? I opened the back and it’s not clear what the battery even is. Thanks for your help guys

Have look here :

I’ve detached the battery and left for an hour but no luck. Will have to flash firmware. Any good YouTube videos showing how to do this?

Actually may not matter as the device won’t even connect to my laptop just keeps attempting to connect making the sound but then windows says the device failed to connect and may not be working properly.

Is it possible adding watch faces did this or more likely faulty hardware? It’s only 24 hours old

Is it possible adding watch faces did this or more likely faulty hardware? It’s only 24 hours old

Does it boot to a spinning logo and then stops? Or does it fail to power on at all?
Either way - read up on the guides in our relative sections and watch this
If you have trouble locating the stock D5 firmware go to the No1 website:
2016 Mar 10:

Doesn’t power on atall I will have a look at the video though thanks

This happened with me but after i took the back cover the problem was solved and it turned on normally